Page 2 of 2

Re: New Winplan32 V3.6.63 released

Posted: Tue Jul 01, 2014 12:04 am
by Rearview
I'm going to have to bow out for now. I've had some credits and supplies appear from nowhere when using the client 3 times (in games not hosted here, and luckily the guy running the host has fixed it for me).

Today in my No Frills 127 game I had two planets' colonists all die of plague because 2 credits appeared from nowhere. Luckily I didn't have starbases at them. I've really enjoyed the convenience of the 32 bit client, but I can't deal with the host telling my good turn and then this happening. I can troubleshoot anything you need if you want (once I return from vacation).

Re: New Winplan32 V3.6.63 released

Posted: Wed Jul 02, 2014 5:27 am
by Andor
Bitmask, In your first post in this topic there is a picture. My issue is when I press the Green up arrow to cycle through ships it looks at only the even number IDs. When I press the Down green button it cycles through the even IDs until it reaches the highest ID. It then goes to the lowest odd ID and only cycles through odd IDs after that.


Ships IDs: 111, 112, 113, 114, 115, 116

Pressing up it cycles through: 112, 116, 114, 112 (skipping odd numbers)
Pressing down starting from an even number: 112, 114, 116, 111, 113, 115, 111 (skipping even numbers after first cycle)

I have noticed this in the past with No Frills 119, but it was infrequent and never had the time to report. In No Frills 130 it is happening on turn 1 with Player 11 rst.

I have tried installing Winplan32 3.6.63 on XP 32 bit and 64 bit Virtual Machines, Windows 98 SE Virtual Machine, and on my Windows 7 host machine. All installations I have the same issue.

I have tried Winplan32 3.6.62 and 3.6.45 and I have the same issue.

I've installed WinPlan 3.52.025 on the Windows 98 SE and it cycles through the ships as expected.

Also for the first time Echoview cannot find these ships if I use Shift + F3 to see the next turn prediction. If I click where they were, Echoview closes without as much as a warning message. This is also my first time playing a Wandering Tribes game so I don't know if that is expected or not.

Re: New Winplan32 V3.6.63 released

Posted: Wed Jul 02, 2014 7:51 am
by Gavan
I have seen the odd / even thing with changing SB's before and my echoview is also not showing the next turn with Wandering Tribes but I have used winplan 32-bit on other games without the same next turn problem.

I am kind of hoping this will go away next turn. #-o

Re: New Winplan32 V3.6.63 released

Posted: Wed Jul 02, 2014 9:31 am
by BitMask
I have fixed that up\down issue before, but I think it was when pressing the keyboard shortcuts. I'll look at it again.

I don't have any suggestion to your Echoview issue, but it might by a Wondering Tribe issue cause you have no history and no owned planets. I suggest you don't predict until next turn.

Re: New Winplan32 V3.6.63 released

Posted: Wed Jul 02, 2014 10:06 am
by Andor
In all my days I have never used the keyboard shortcut to cycle through my ships. Didn't even think to use such a thing, I guess I like the big green triangles that much. :lam:

I can confirm the keyboard shortcut fix you have made in the past works. Would be nice to be able to trust the big green triangles again, but until that day I'll use the keyboard shortcut for now.

Re: New Winplan32 V3.6.63 released

Posted: Wed Jul 02, 2014 5:08 pm
by BitMask
Hmm. Neither my development version or the 63 version is giving me this error on the green arrows.
Have you tested this all on the same turn, or one different turns?

Re: New Winplan32 V3.6.63 released

Posted: Thu Jul 03, 2014 12:27 am
by Andor
I only have the one No Frills 130 RST. I have all my older RST files I may have to dig through them, but first I tried a few different things:

Resent RST to my primary gmail account I use - no change
Updated primary email to use my ISP and resent to that address - no change
Used both Outlook 2010 and Google Chrome to retrieve attachments - no difference

Tried reinstalling and just after it registers some OCX and dll files I get an error

Registering: C:\Windows\system32\TABCTL32.OCX
Registering: C:\Windows\system32\threed32.ocx
Could not load: C:\Windows\system32\VB6.OLB

Installed Visual Studios 6 on Win 2k Pro Virtual Machine, verified the presence of VB6.OLB, re-ran installer - no change
It still said "Could not load: C:\WINNT\system32\VB6.OLB"

Installed Tim's WINPLAN 3.5 on Win 2k Pro, copied PLAN1 directory over to Win 7 Host machine, replaced Winplan.exe with Winplan32.exe, and added registration files - no change

I can give you the Global IP address for one of my XP VMs if you'd like. If interested send me a PM and we can arrange a time and date when you can RDP or VNC in. No rush I'm fine with the keyboard shortcuts for the time being. If need I will try to find more RST files from No Frills 119 and write down which ship IDs it does it on.

Re: New Winplan32 V3.6.63 released

Posted: Thu Jul 03, 2014 8:57 am
by BitMask
Just check if the next turn also give you the same problem and let me know.

Re: New Winplan32 V3.6.63 released

Posted: Sat Jul 05, 2014 11:39 pm
by Andor
It's doing it again, slightly different behavior because I colonized a ship. The new sequence is:

Ship ID 112 colonized

Up arrow
113, 111, 116, 114, 111, 116, 114, 111, 116 ....

Down arrow
116, 111, 113, 115, 111, 113, 115, 111, 113 ....

Only way to see all ships is to use the keyboard shortcut. If that's what I have to use I'm fine with that.

Re: New Winplan32 V3.6.63 released

Posted: Sun Jul 06, 2014 4:18 pm
by Gavan
Echoview is happy again this turn. I can now see the future :D

Re: New Winplan32 V3.6.63 released

Posted: Sun Jul 27, 2014 4:48 pm
by Gavan
Echoview is back at it for the last two turns.

I open Echoview and select the game and Echoview flashs up and then crashes but is still happy to open into a different game.

Does anyone know if there is a "safe mode" for Echoview so that I can test out which setting might be the cause of this problem?

Re: New Winplan32 V3.6.63 released

Posted: Sun Jul 27, 2014 8:27 pm
by Andor
You could try deleting your Echoview.INI and econfig.txt file in that particular games VPWORKS directory.If that doesn't work, you can try loading your RSTs one-at-a-time into a fresh VPWORKS directory. Each time you unpack an RST open, then save/close Echoview so you can retain turn history.

Re: New Winplan32 V3.6.63 released

Posted: Wed Jul 30, 2014 11:51 pm
by Gavan
Thanks Andor but no luck. Echoview still crashes when I open my turn in that game.

Maybe it will "magically" get better at some point.